Quest debug assistance

Welcome in the osRose emulator Project.

Moderators: osRose dev team, ospRose dev team, osiRose dev team, Moderators

Quest debug assistance

Postby crazycabling on Tue Dec 18, 2018 9:38 pm

Hi!

I am using client 434 and the 2016 Animal release server.

I am trying see why Quest 36 (Honey for the Honey) given by Magdalena in the village of Luxem is giving me an issue.

The IFO declaration with quest name and coordinates is added to list_objects on the server’s SQL.

When I stand at the right location in Luxem, the block triggers properly (Ex: Q36_Honey_1 inside Q21-001.QSD). The 0x731 packet is sent from the client and the server responds with a quest trigger then I see the dds image “splash text” that the honey sample was found in the client so its associated LUA function (Q36-Honey inside the tutorial.lua script) is working.

The quest variables get incremented, for this case, honey sample at location 1 increments the quest 36 variable 0 by 1 then the item 13046 is given (Honey Sample) but the sample icon does not appear in the Honey for the Honey quest holder unless I reload the character by a char select or a logout-login. Once I reload, the samples I have collected are there and I can cash the quest in with the NPC once I have the required 5 samples.

Does anyone have any suggestions as to why the icon does not appear on sample discovery?

I know I must have missed something…

Please let me know if you need to see configs or files and I will post them.

Thank You kindly and have a great day,

Crazycabling
crazycabling
Little soul
Little soul
 
Posts: 2
Joined: Tue Dec 18, 2018 6:22 pm

Re: Quest debug assistance

Postby L3nn0x on Tue Dec 18, 2018 10:36 pm

I haven't worked with quests nor your specific server so it might be wrong.

Have you verified that you're correctly sending the updated quest data to the client? From what I understand of quests, you have to send a packet to update them.
L3nn0x
osiRose dev
osiRose dev
 
Posts: 110
Joined: Wed Oct 21, 2015 8:22 pm

Re: Quest debug assistance

Postby crazycabling on Wed Dec 19, 2018 12:57 am

@L3nn0x
Thank You! You are right. I experimented with packet 730 and 731 and commented out a 731 recall packet from questactions.cpp that I should not. Once I revised and recompiled it worked.

Thank you again.
crazycabling
Little soul
Little soul
 
Posts: 2
Joined: Tue Dec 18, 2018 6:22 pm

Re: Quest debug assistance

Postby L3nn0x on Sat Dec 22, 2018 6:25 am

Glad I could help! Have fun tinkering with Rose!
L3nn0x
osiRose dev
osiRose dev
 
Posts: 110
Joined: Wed Oct 21, 2015 8:22 pm


Return to Support - OsRose Emulator

Who is online

Users browsing this forum: No registered users and 6 guests

cron