Release

A project which includes source code for an old and somewhat unique evo client and an OsRose server which comprises of an old rev81 combined with KTRose pre-evo. Many new features in both client and server

Release

Postby Elyntra on Sat Jul 28, 2018 9:50 pm

For a short time, a few people and I were working with the 137 files. Here is everything we managed to do. Thank you everyone for your time spent on these files.

https://mega.nz/#!Vp0D3RDQ!iPJUGn4OFu12 ... EVxSft0kLc
https://mega.nz/#!580VVZhB!IkjQodXA0OVk ... GerhYqw7As
https://mega.nz/#!V48XTZqS!6WHNuaZ9qwUS ... tZqM5-2Ttw
Elyntra
Jelly Bean
Jelly Bean
 
Posts: 15
Joined: Wed May 16, 2018 6:56 am

Re: Release

Postby rl2171 on Sun Jul 29, 2018 8:48 pm

What kind of updates/changes were you and the group able to do?

Thank you!
Image
rl2171
Admin
Admin
 
Posts: 1684
Joined: Mon Aug 06, 2007 5:17 pm
Location: Sacramento, CA USA - GMT-8

Re: Release

Postby Elyntra on Tue Jul 31, 2018 2:47 pm

Lazypenguin cleaned up the sources which fixed a lot of problems we were having. Allowed us to actually run the client. Big thank you to him for that. Purple fixed some crashes related to the quest system.

Unfortunately we don't have a list of the fixes anymore. Thank you to Lazypenguin, PurpleYouko and Neanne for their time spent in the 137 code.

A few bugs I remember that are still there are.

NPC Rotation: Just export a new npc sql from the maps and it will work.
Mob Spawns: Purple changed the monster spawns to a new sql which hasn't had all spawns converted to it.
Client doesn't compile in release mode, only debug. In debug, you can see marks for all effects.

I know there were more but unfortunately I can't remember them.
Elyntra
Jelly Bean
Jelly Bean
 
Posts: 15
Joined: Wed May 16, 2018 6:56 am

Re: Release

Postby PurpleYouko on Tue Jul 31, 2018 3:47 pm

The server projects were combined into one solution so that they all load in at once. Made it easier to handle.

Unfortunately Penguin's new project settings turned out to be a lot less forgiving than the ones that the project started out with.
This served to highlight a ton of bugs that we didn't know were there.
Almost all of them were related to badly set up variables that had either incomplete constructors or none at all, leaving a whole bunch of variables uninitialized and containing stupid values.
These stupid values were causing seemingly random crashes in the client when they were sent through in packets.

Almost all of the code fixes were related to fixing these issues. We more or less got them all completed just in time for the group to fall apart.

So basically this codebase should be somewhat more stable than previously available 137 server sources but doesn't really contain any new content at this time.
The project is much nicer and easier to work with now so all the back end work put in by penguin and neanne to get it set up have been extremely good for teh project.

Right now I'm still plugging away at it the way I have been on and off for the last few years so watch this space (possibly for a very long time) for any further developments.

Thanks guys :D
Need to lookup information on NARose items, skills, quests?
Now featuring a newly completed skill tree for all classes
Formatting fixed for different resolutions
Image

"A Gazelle is nothing but a giraffe plotted logarithmicaly"
User avatar
PurpleYouko
Rose Guru
Rose Guru
 
Posts: 4621
Joined: Fri Aug 10, 2007 2:05 pm

Re: Release

Postby Circa on Wed Aug 01, 2018 2:32 am

Guessing this doesn't work on vs2017?
Circa
Clown
Clown
 
Posts: 403
Joined: Sun Aug 23, 2009 5:52 am
Location: CA

Re: Release

Postby Elyntra on Thu Aug 02, 2018 7:36 am

Circa wrote:Guessing this doesn't work on vs2017?

I believe it needs vs2010.
Elyntra
Jelly Bean
Jelly Bean
 
Posts: 15
Joined: Wed May 16, 2018 6:56 am

Re: Release

Postby adosorken on Sat Feb 02, 2019 4:54 am

I'm still watching this space. Just so ya know. :D
Evolve this!!
User avatar
adosorken
Smoulie
Smoulie
 
Posts: 57
Joined: Sat Aug 20, 2016 3:29 pm
Location: Windsor, VT

Re: Release

Postby adosorken on Sat Feb 02, 2019 6:43 am

After three days of messing around with this, I finally managed to build the entire thing. The database listing is missing two fields but I got them in so that worldserver would run. However, the client crashes on startup. It could be anything, really... when compiling all of these, everything had massive lists of warnings.

EDIT: This is where is buggers up, it seems:

  1. bRet = ::attachWindow((const void*)g_pCApp->GetHWND());

line 61 in winMAIN.cpp

but I'm guessing that the actual issue is elsewhere.

EDIT2: The actual issue is somewhere in here:

  1. ZZ_DLL
  2. int attachWindow (const void * window_handle)
  3. {
  4.     zz_assertf(znzin, "엔진이 초기화되지 않았습니다.");
  5.     zz_assert(znzin->view);
  6.     zz_assert(znzin->sfxs);
  7.  
  8.     znzin->view->set_handle((const void*)window_handle);
  9.     if (!znzin->view->attach_window()) return 0;
  10.     if (!znzin->sfxs->initialize()) return 0;
  11.  
  12.     return 1;
  13. }

starting around line 2120 in zz_interface.cpp

Unfortunately, I cannot get ZZ_LOG to output anything, and I'm not quite sure why.
Last edited by adosorken on Sat Feb 02, 2019 4:51 pm, edited 1 time in total.
Evolve this!!
User avatar
adosorken
Smoulie
Smoulie
 
Posts: 57
Joined: Sat Aug 20, 2016 3:29 pm
Location: Windsor, VT

Re: Release

Postby PurpleYouko on Sat Feb 02, 2019 4:31 pm

Don't concern yourself with warnings at this point. They are almost always related to possible loss of data during calculations containing more than one data type
Need to lookup information on NARose items, skills, quests?
Now featuring a newly completed skill tree for all classes
Formatting fixed for different resolutions
Image

"A Gazelle is nothing but a giraffe plotted logarithmicaly"
User avatar
PurpleYouko
Rose Guru
Rose Guru
 
Posts: 4621
Joined: Fri Aug 10, 2007 2:05 pm

Re: Release

Postby adosorken on Sat Feb 02, 2019 4:53 pm

Yeah, not too worried about that part, just trying to isolate the cause of the client crash. I've traced it down to a possible issue in znzin.dll. I can't get ZZ_LOG to work so I can't really trace it any further.
Evolve this!!
User avatar
adosorken
Smoulie
Smoulie
 
Posts: 57
Joined: Sat Aug 20, 2016 3:29 pm
Location: Windsor, VT

Next

Return to Support -- Project 137

Who is online

Users browsing this forum: No registered users and 0 guests

cron